반응형
문제(출처)
정수를 저장하는 큐를 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.
명령은 총 여섯 가지이다.
push X: 정수 X를 큐에 넣는 연산이다.
pop: 큐에서 가장 앞에 있는 정수를 빼고, 그 수를 출력한다.
만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
size: 큐에 들어있는 정수의 개수를 출력한다.
empty: 큐가 비어있으면 1, 아니면 0을 출력한다.
front: 큐의 가장 앞에 있는 정수를 출력한다.
만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
back: 큐의 가장 뒤에 있는 정수를 출력한다.
만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
입력
첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다.
둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다.
주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다.
문제에 나와있지 않은 명령이 주어지는 경우는 없다.
출력
출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.
예제 입력
15
push 1
push 2
front
back
size
empty
pop
pop
pop
size
empty
pop
push 3
empty
front
예제 출력
1
2
2
0
1
2
-1
0
1
-1
0
3
내 풀이
package date_20190129;
import java.io.BufferedReader;import java.io.BufferedWriter;import java.io.IOException;import java.io.InputStreamReader;import java.io.OutputStreamWriter;
class MyQueue{ private int size; private Node node; class Node { private int value; private Node nextNode; public Node() { } public Node(int value) { this.value = value; this.nextNode = null; } } public void push(int value) { Node newNode = new Node(value); if(this.node == null) { this.node = newNode; }else { Node temp = this.node; while(temp.nextNode != null) { temp = temp.nextNode; } temp.nextNode = newNode; } this.size++; } public int pop() { int value = 0; if(this.node == null) { return -1; }else { value = this.node.value; this.node = this.node.nextNode; } this.size--; return value; } public int size() { return this.size; } public int empty() { if(this.node == null) { return 1; }else { return 0; } } public int front() { if(this.node == null) { return -1; } return this.node.value; } public int back() { if(this.node == null) { return -1; } Node temp = this.node; while(temp.nextNode != null) { temp = temp.nextNode; } return temp.value; }}
public class BOJ_10845 {// 큐 만들기// push X: 정수 X를 큐에 넣는 연산이다.// pop: 큐에서 가장 앞에 있는 정수를 빼고, 그 수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.// size: 큐에 들어있는 정수의 개수를 출력한다.// empty: 큐가 비어있으면 1, 아니면 0을 출력한다.// front: 큐의 가장 앞에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.// back: 큐의 가장 뒤에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다. public static void main(String args[]) throws NumberFormatException, IOException { BufferedReader br = new BufferedReader(new InputStreamReader(System.in)); BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out)); int num = Integer.parseInt(br.readLine()); String[] str = new String[2]; int result = 0; MyQueue q = new MyQueue(); for(int i = 0; i < num; i++) { str = br.readLine().split(" "); result = queueRun(str, q); if(result != -2) { bw.write(String.valueOf(result)); bw.newLine(); } } bw.close(); } public static int queueRun(String[] str, MyQueue q) { int result = 0; switch(str[0]) { case "push" :{ q.push(Integer.parseInt(str[1])); result = -2; break; } case "pop" :{ result = q.pop(); break; } case "size" :{ result = q.size(); break; } case "empty" :{ result = q.empty(); break; } case "front" :{ result = q.front(); break; } case "back" :{ result = q.back(); break; } } return result; }}
package date_20190129;
import java.io.BufferedReader;
import java.io.BufferedWriter;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.OutputStreamWriter;
class MyQueue{
private int size;
private Node node;
class Node {
private int value;
private Node nextNode;
public Node() {
}
public Node(int value) {
this.value = value;
this.nextNode = null;
}
}
public void push(int value) {
Node newNode = new Node(value);
if(this.node == null) {
this.node = newNode;
}else {
Node temp = this.node;
while(temp.nextNode != null) {
temp = temp.nextNode;
}
temp.nextNode = newNode;
}
this.size++;
}
public int pop() {
int value = 0;
if(this.node == null) {
return -1;
}else {
value = this.node.value;
this.node = this.node.nextNode;
}
this.size--;
return value;
}
public int size() {
return this.size;
}
public int empty() {
if(this.node == null) {
return 1;
}else {
return 0;
}
}
public int front() {
if(this.node == null) {
return -1;
}
return this.node.value;
}
public int back() {
if(this.node == null) {
return -1;
}
Node temp = this.node;
while(temp.nextNode != null) {
temp = temp.nextNode;
}
return temp.value;
}
}
public class BOJ_10845 {
// 큐 만들기
// push X: 정수 X를 큐에 넣는 연산이다.
// pop: 큐에서 가장 앞에 있는 정수를 빼고, 그 수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
// size: 큐에 들어있는 정수의 개수를 출력한다.
// empty: 큐가 비어있으면 1, 아니면 0을 출력한다.
// front: 큐의 가장 앞에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
// back: 큐의 가장 뒤에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
public static void main(String args[]) throws NumberFormatException, IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
int num = Integer.parseInt(br.readLine());
String[] str = new String[2];
int result = 0;
MyQueue q = new MyQueue();
for(int i = 0; i < num; i++) {
str = br.readLine().split(" ");
result = queueRun(str, q);
if(result != -2) {
bw.write(String.valueOf(result));
bw.newLine();
}
}
bw.close();
}
public static int queueRun(String[] str, MyQueue q) {
int result = 0;
switch(str[0]) {
case "push" :{
q.push(Integer.parseInt(str[1]));
result = -2;
break;
}
case "pop" :{
result = q.pop();
break;
}
case "size" :{
result = q.size();
break;
}
case "empty" :{
result = q.empty();
break;
}
case "front" :{
result = q.front();
break;
}
case "back" :{
result = q.back();
break;
}
}
return result;
}
}
내 풀이 해석
기본적으로 사용 되는 큐의 6가지 기능을 구현했습니다.
반응형
'개발(합니다) > 알고리즘&코테' 카테고리의 다른 글
[프로그래머스-코테연습] 모의고사 (0) | 2021.06.23 |
---|---|
[프로그래머스-코테연습] K번째 수 (0) | 2021.06.22 |
알고리즘 단계별로 풀어보기 : BOJ-2504(괄호의값) (0) | 2019.01.28 |
알고리즘 단계별로 풀어보기 : BOJ-9012(괄호) (0) | 2019.01.26 |
알고리즘 단계별로 풀어보기 : BOJ-1874(스택수열) (0) | 2019.01.25 |