본문 바로가기

개발(합니다)/알고리즘&코테

알고리즘 단계별로 풀어보기 : BOJ-1157(단어공부)

반응형

문제(출처)

알파벳 대소문자로 된 단어가 주어지면, 이 단어에서 가장 많이 사용된 알파벳이 무엇인지 알아내는 프로그램을 작성하시오. 

단, 대문자와 소문자를 구분하지 않는다.


입력

첫째 줄에 알파벳 대소문자로 이루어진 단어가 주어진다. 

주어지는 단어의 길이는 1,000,000을 넘지 않는다.


출력

첫째 줄에 이 단어에서 가장 많이 사용된 알파벳을 대문자로 출력한다. 
단, 가장 많이 사용된 알파벳이 여러 개 존재하는 경우에는 ?를 출력한다.


예제 입력1

Mississipi


예제 출력1

?


예제 입력2

zZa


예제 출력2

Z


내 풀이

import java.io.BufferedReader;
import java.io.BufferedWriter;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.OutputStreamWriter;

public class Main {
    public static void main(String args[]) {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
//      System.out.println((int) 'a'); // 97
//      System.out.println((int) 'z'); // 122
//      System.out.println((int) 'A'); // 65
//      System.out.println((int) 'Z'); // 90
        
        try {
            String str = br.readLine();
//          문자열을 입력받습니다.
            int[] alphabetList = initAlphabet();
//          알파벳 리스트를 소문자 아스키코드로 초기화합니다.
            int[] alphabetCheck = alphabetCheck(str, alphabetList);
//          입력 받은 문자열과 알파벳 리스트를 비교합니다.(대소문자 포함)
//          개수를 세어 alphabetCheck 정수형 배열에 저장합니다.
            int max = maxCheck(alphabetCheck);
//          개수를 세어 본 alphabetCheck 배열의 최고 값을 찾아 반환합니다.
            int duplicateMax = duplicateMaxCheck(alphabetCheck, max);
//          최고 값이 유일한지 확인합니다.
            
            if(duplicateMax > 1) {
//              유일하지 않으면 '?'를 출력하고 유일하지 않다면 최고 값을 찾아 출력합니다.
                bw.write("?");
            }else {
                for(int i = 0; i < alphabetCheck.length; i++) {
                    if(max == alphabetCheck[i]) {
                        bw.write(String.valueOf((char)alphabetList[i]));
                    }
                }
            }
            
            bw.flush();
            bw.close();
            
            
        } catch (IOException e) {
            e.printStackTrace();
        }
    }
    
    private static int[] initAlphabet() {
        int[] alphabet = new int[26];
        for(int i = 0; i < alphabet.length; i++) {
            alphabet[i] = 65+i;
        }
        return alphabet;
    }
    
    private static int maxCheck(int[] alphabetCheck) {
        int max = 0;
        for(int i : alphabetCheck) {
            if(max < i) {
                max = i;
            }
        }
        return max;
    }
    
    private static int duplicateMaxCheck(int[] alphabetCheck, int max) {
        int duplicateMax = 0;
        for(int i : alphabetCheck) {
            if(max == i) {
                duplicateMax++;
            }
        }
        return duplicateMax;
    }
    
    private static int[] alphabetCheck(String str, int[] alphabetList) {
        int[] alphabetCheck = new int[26];
        for(int j = 0; j < alphabetList.length; j++) {
            for(int i = 0; i < str.length(); i++) {
                if(str.charAt(i) == alphabetList[j] || str.charAt(i) == (alphabetList[j]+32)) {
                    alphabetCheck[j]++;
                }
            }
        }
        return alphabetCheck;
    }
}


내 풀이 해석

입력 받은 문자열을 저장합니다.
알파벳 리스트를 만들어 배열에 아스키 코드로 저장합니다.
문자열과 알파벳 리스트를 비교해서 문자열의 개수를 세어 알파벳 체크 배열 변수에 저장합니다.
알파벳 배열 변수에서 최고값을 찾고 유일한지를 확인 후 출력합니다.

아쉬운 점

항상 프로그래밍을 하다보면 더 잘 짤 수 있는 방법이 있을텐데.. 하고 아쉬움이 남습니다.


반응형